Need help naming a class which represents a value and its linear variation -
While refactoring, I've found that I'm often using a pair or float to represent the initial value For a long time, this value varies from linear form. I want to make a straight line to catch both areas but I can not find the right name for this.
It should look something like this:
struct XXX {float value; Boat slope; // Delta? This difference? }
Any suggestions will be highly appreciated.
Since you have an initial value, and it shows how 'some' develops , You can go with some things like "Linear Function".
I will add the necessary member functions:
straight linear function {Float continuous; Boat slope; Float Incharm (Float Delta) Const. {Return Stable + Delta * Slope; } Add zero (conif liner function and others) {constant + = other.contstant; Slope + = other Slopes; } Linear functions invert () const {LinearFunction inv = {-constant / slope, 1./slope; }; Return; }};
Am I curious here?
Comments
Post a Comment